render on top of precipitation

Materials, textures, lighting, postfx
5 posts Page 1 of 1
fLUnKnhaXYU
Posts: 84
Joined: Wed Nov 15, 2017 8:19 am
by fLUnKnhaXYU » Thu Dec 27, 2018 11:52 pm
hello , Rendering a material on top of the precipitation layer . the material is 1 of two from the building , glass , it uses a cube map reflection but with it using no cubemap does the same .
Image

torque3d version 3.9
Sectors Demo , model is building_01 , material is glassMat
JeffR
Steering Committee
Steering Committee
Posts: 937
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Sat Dec 29, 2018 9:07 pm
Wow, that's pretty wild. Does it utilize any sort of transparency or alpha testing?
fLUnKnhaXYU
Posts: 84
Joined: Wed Nov 15, 2017 8:19 am
by fLUnKnhaXYU » Sat Dec 29, 2018 10:15 pm
This is the models material file for that particular material .

singleton Material(building_01_glassMat)
{
	mapTo = "glassMat";

	normalMap[0] = "art/shapes/building1/building_01_nm.tga";
	specularMap[0] = "art/shapes/building1/building_01_spec.tga";

	diffuseColor[0] = "0.152941 0.423529 0.443137 1";
	specular[0] = "1 1 1 1";
	specularPower[0] = "54";

	doubleSided = false;
	translucent = "1";
	translucentBlendOp = "LerpAlpha";
   pixelSpecular[0] = "0";
   cubemap = "GoldenHourCloudySkyCubeMap";
   materialTag0 = "RoadAndPath";
   glow[0] = "0";
};
This is from the .MIS
new Precipitation(snowT1) {
      numDrops = "100000";
      boxWidth = "200";
      boxHeight = "100";
      dropSize = "1";//------------------The size in the original picture was more like 5
      splashSize = "0.5";
      splashMS = "250";
      animateSplashes = "1";
      dropAnimateMS = "0";
      fadeDist = "0";
      fadeDistEnd = "0";
      useTrueBillboards = "0";
      useLighting = "0";
      glowIntensity = "0 0 0 0";
      reflect = "0";
      rotateWithCamVel = "1";
      doCollision = "1";
      hitPlayers = "0";
      hitVehicles = "0";
      followCam = "1";
      useWind = "0";
      minSpeed = "1.5";
      maxSpeed = "2";
      minMass = "0.75";
      maxMass = "0.85";
      useTurbulence = "0";
      maxTurbulence = "0.1";
      turbulenceSpeed = "0.2";
      dataBlock = "HeavySnow";
      position = "738 -56 170";
      Rotation = "1 0 0 0";
      scale = "1 1 1";
      canSave = "1";
      canSaveDynamicFields = "1";
   };
JeffR
Steering Committee
Steering Committee
Posts: 937
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Mon Dec 31, 2018 3:55 pm
Hmm....

It's obviously going to screw with the look, but can you try turning off this:

Code: Select all

translucent = "1"; translucentBlendOp = "LerpAlpha";
I'd wager that's causing the order fighting, but figure we can turn it off real fast to double-check that's the case to confirm the supposition.
fLUnKnhaXYU
Posts: 84
Joined: Wed Nov 15, 2017 8:19 am
by fLUnKnhaXYU » Mon Dec 31, 2018 9:10 pm
You are Right Jeff . I unchecked transparency in the editor and it looked right . Thanks for your time .
5 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 15 guests