Occulus Rift DK2 [ALSO: OpenVR]

Materials, textures, lighting, postfx
  • 1
  • 2
  • 3
  • 4
  • 5
  • 9
89 posts Page 2 of 9
JeffR
Steering Committee
Steering Committee
Posts: 878
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Thu Jun 04, 2015 5:57 pm
It should work fine without a headset set up.

Something may not be getting initialized in script somewhere.

Got the full log file we can look through?
LordThrash
Posts: 7
Joined: Wed Apr 15, 2015 11:59 pm
by LordThrash » Sat Jun 06, 2015 5:20 am
hi. I hope this is the log you want. If there is another log that would be helpful, let me know. I have been ignoring the pdb errors... This is a straight build from github torque3d development. I made a sister build without oculus on the same code and it worked fine.

I was going to deactivate fmod and see what happens.

[code]'Spear_Dev_DEBUG.exe': Loaded 'D:\BioCy\spear\Torque3D-development\My Projects\Spear_Dev\game\Spear_Dev_DEBUG.exe', Symbols loaded.
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\ntdll.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\kernel32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\KernelBase.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\user32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\gdi32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\lpk.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\usp10.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\msvcrt.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\advapi32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\sechost.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\rpcrt4.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\sspicli.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\cryptbase.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\imm32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\msctf.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'D:\BioCy\spear\Torque3D-development\My Projects\Spear_Dev\game\Spear_Dev_DEBUG DLL.dll', Symbols loaded.
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\X3DAudio1_7.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\comdlg32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\shlwapi.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.7601.18201_none_ec80f00e8593ece5\comctl32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\shell32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\winmm.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\wsock32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\ws2_32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\nsi.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\d3d9.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\version.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\d3d8thk.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\dwmapi.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\D3DX9_43.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\ole32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\oleaut32.dll', Cannot find or open the PDB file
Input Init:
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\XInput9_1_0.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\setupapi.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\devobj.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\dinput8.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\hid.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\wintrust.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\crypt32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\msasn1.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\uxtheme.dll', Cannot find or open the PDB file
keyboard0 input device created.
mouse0 input device created.
DirectInput enabled.

Done
'Spear_Dev_DEBUG.exe': Loaded 'C:\Program Files (x86)\SlySoft\AnyDVD\ADvdDiscHlp.dll', Binary was not built with debug information.
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\clbcatq.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\XAudioD2_7.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\MMDevAPI.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\propsys.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\OpenAL32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\wdmaud.drv', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\ksuser.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\avrt.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\AudioSes.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\msacm32.drv', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\msacm32.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\midimap.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\wrap_oal.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\dsound.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\powrprof.dll', Cannot find or open the PDB file
The thread 'Win32 Thread' (0x360c) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x23e4) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2ae4) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x23c4) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x3718) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x69c) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x3680) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x23dc) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2c48) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2348) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x376c) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x1f50) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2eb4) has exited with code 0 (0x0).
'Spear_Dev_DEBUG.exe': Unloaded 'C:\Windows\SysWOW64\wrap_oal.dll'
'Spear_Dev_DEBUG.exe': Loaded 'C:\Windows\SysWOW64\wrap_oal.dll', Cannot find or open the PDB file
The thread 'Win32 Thread' (0x2a28) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x19b8) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2ccc) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x27f0) has exited with code 0 (0x0).
'Spear_Dev_DEBUG.exe': Unloaded 'C:\Windows\SysWOW64\wrap_oal.dll'
'Spear_Dev_DEBUG.exe': Loaded 'D:\BioCy\spear\Torque3D-development\My Projects\Spear_Dev\game\fmodex.dll', Cannot find or open the PDB file
'Spear_Dev_DEBUG.exe': Loaded 'D:\BioCy\spear\Torque3D-development\My Projects\Spear_Dev\game\fmod_event.dll', Cannot find or open the PDB file
SFXFMODProvider - FMOD Ex API version: 4.44.31
SFXFMODProvider - FMOD Designer API version: 4.44.31
The thread 'Win32 Thread' (0x37f4) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2918) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x8a4) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2f80) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2acc) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2e30) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x21d0) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x358c) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x9d0) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2434) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x2600) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0x3158) has exited with code 0 (0x0).
Oculus VR Device Init:
Could not enumerate a HMD device. Simulating a HMD.
First-chance exception at 0x11022206 (Spear_Dev_DEBUG DLL.dll) in Spear_Dev_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000040.
Unhandled exception at 0x11022206 (Spear_Dev_DEBUG DLL.dll) in Spear_Dev_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000040.[/code]
LordThrash
Posts: 7
Joined: Wed Apr 15, 2015 11:59 pm
by LordThrash » Sat Jun 06, 2015 5:24 am
I just realized I think I used the older project generator. I will try the latest.
buckmaster
Steering Committee
Steering Committee
Posts: 321
Joined: Thu Feb 05, 2015 1:02 am
by buckmaster » Wed Jun 17, 2015 10:46 am
I'm having issues with this with the release-3.7 branch merged in. Might there be code we need to update? Compiler errors:
Error error LNK2001: unresolved external symbol "private: static class EngineClassTypeInfo<class GuiOffscreenCanvas,struct _Private::_ConcreteClassBase<class GuiOffscreenCanvas> > GuiOffscreenCanvas::_smTypeInfo" (?_smTypeInfo@GuiOffscreenCanvas@@0V?$EngineClassTypeInfo@VGuiOffscreenCanvas@@U?$_ConcreteClassBase@VGuiOffscreenCanvas@@@_Private@@@@A) C:\code\Torque3D\My Projects\37rc\buildFiles\VisualStudio 2012\projects\guiTSControl.obj

Error error LNK2001: unresolved external symbol "public: static class Vector<class GuiOffscreenCanvas *> GuiOffscreenCanvas::sList" (?sList@GuiOffscreenCanvas@@2V?$Vector@PAVGuiOffscreenCanvas@@@@A) C:\code\Torque3D\My Projects\37rc\buildFiles\VisualStudio 2012\projects\guiCanvas.obj
(Windows 7 x64, VS2012, no Oculus enabled.)
rlranft
Posts: 298
Joined: Thu Feb 05, 2015 3:11 pm
 
by rlranft » Wed Jun 17, 2015 2:51 pm
hi. I hope this is the log you want.
Nope - In the game folder of your project there should be a console.log file - that will show what the engine was doing up until the crash.
LordThrash
Posts: 7
Joined: Wed Apr 15, 2015 11:59 pm
by LordThrash » Fri Jul 10, 2015 8:16 am
I got latest 3.7 and trying again with occlus sdk 0.5 all bone stock.
First I had trouble with the OVR.h includes. I resolved it by adding the sdk files listed in into new folder LibOVR\Include\Kernel. Was that bad?
Now I'm hitting this when compiling in vs2010

Code: Select all

1>d:\biocy\37bin\engine\source\platform\input\oculusvr\oculusvrhmddevice.h(47): error C2039: 'HMDDevice' : is not a member of 'OVR' 1>d:\biocy\37bin\engine\source\platform\input\oculusvr\oculusvrhmddevice.h(47): error C2143: syntax error : missing ';' before '*' 1>d:\biocy\37bin\engine\source\platform\input\oculusvr\oculusvrhmddevice.h(47): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
on this line:

Code: Select all

OVR::HMDDevice* mDevice;
Im pretty noobie at this. Suggestions welcome.
-Rob
PaulWeston
Posts: 143
Joined: Thu Apr 23, 2015 7:16 pm
by PaulWeston » Thu Oct 29, 2015 10:53 pm
I am also getting this error when trying to run a build of T3D 3.8 using Oculus SDK 0.5:

Code: Select all

Oculus VR Device Init: Could not enumerate a HMD device. Simulating a HMD. First-chance exception at 0x11022206 (Spear_Dev_DEBUG DLL.dll) in Spear_Dev_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000040. Unhandled exception at 0x11022206 (Spear_Dev_DEBUG DLL.dll) in Spear_Dev_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000040.
Causes game to crash right away.

Compile was flawless, not sure why this is happening.

Used to have Oculus working fine in 3.6.3 (with older 0.1.5 Oculus SDK) before all the changes for DK2.

But I would like to move my code up to 3.8, for many reasons especially any updated x64 stuff.

Ideas anyone?
PaulWeston
Posts: 143
Joined: Thu Apr 23, 2015 7:16 pm
by PaulWeston » Wed Feb 10, 2016 3:50 am
Trying this repo as well:

https://github.com/Azaezel/Torque3D/tree/afx3.8_DX11

Any way somebody can take a look at the code under platform/input/oculusvr and see about porting that up to DX11? All the refs are for Dx9 in there...

Looking to have a modern build using latest Oculus sdk, which needs dx11, for testing in a dk2 and the new consumer units. Dx9 is no longer supported, as mentioned further up the thread... To stay current and be compatible moving forward that code needs a bit of tweaking...

I'm taking a look, tried replacing dx9 refs with dx11, I know it's not that simple, but am starting there and seeing if I can figure something out. I'm not hopeful though lol.

Anyone up for taking a look?

Thanks cheers
JeffR
Steering Committee
Steering Committee
Posts: 878
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Wed Feb 10, 2016 8:22 am
Mango's probably gunna have the best idea of what's required to get it up to speed, as he was the one spearheading the occulus work before.

I think he'd made a mention of looking at updating it once DX11 is rolled out, but I don't remember if that was a plan, or just musings. Either way, at minimum he'd be the best bet for posting a few pointers on what parts would need touching up to get it to hook with DX11.
Timmy
Posts: 366
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Wed Feb 10, 2016 8:37 am
Feel free to donate me one and i'll get it working :mrgreen:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 9
89 posts Page 2 of 9

Who is online

Users browsing this forum: No registered users and 3 guests