Page 2 of 2

Re: Can't seem to properly import a DAE into Torque

Posted: Thu Mar 03, 2016 6:40 am
by Tiel
I never used them outside of the shape editor, but importing and playing the animations worked fine for me. Creating a new project using the dev branch could help, this isn't the first time someone has reported the prebuilt binaries doing things they shouldn't.

For future reference - torque does not support shape keys from what I recall, its probably best to disable those. Torque needs triangulated meshes but isn't the best at triangulation, its best to let the modeling program do that when exporting. Use translocrot when exporting with the stock exporter, not matrix.
Got back from work and tried re-exporting stuff with that in mind, unfortunately, not much luck.

Once more the animations will play fine in the editor, but when it comes to actually use them in the game they won't trigger.

I tried grabbing a build of the current github development branch of Torque buuut the thing crashes whenever I try to load a level. Something something shaders.
Actually that's not just exclusive to my attempt at porting my project over. It seems like any new project with a build off the repository using the Empty template is doomed to CTD before loading the mission. Not sure why.

Put the files over into a new Full Template project, but again, no luck. Once you get it ingame it'll either be one animation 24/7 or none at all :/

Re: Can't seem to properly import a DAE into Torque

Posted: Thu Mar 03, 2016 6:50 am
by Tiel
Okay this is going to sound really dumb but I got it haha

I switched the shapefile in the datablock from the DTS to the original DAE file, and I guess we're in business! That didn't work before, I think the new export settings did the trick.

Thank you so much for your taking the time to assist. There's a lot of stagnant forums where questions like this get glossed over by disinterested members but I'm glad neither are the case here. Hopefully some day I'll have the opportunity to help someone as you've helped me.