Tutorial: How to compile the new version of Torque3D v3.9

There are no stupid questions, just stupid answers.
30 posts Page 3 of 3
avovana
Posts: 13
Joined: Sun Feb 25, 2018 2:32 am
by avovana » Sun Feb 25, 2018 5:03 am
Hello everyone!

I'm new here. I want to ask some help in the compiling issue.

I have:
1) PC is Intel(R) Core(TM) i5-2410M CPU @ 2.0 GHz 2.30 GHz.
2) NVIDIA GeForce GT 525M.

My enviroment:
1. Windows 7 SP1.
2. Visual Studio 2017 (15.5.5 version).
3. Cmake 3.10.2 (lastest stable version).

In short, what did I do:
  1. Cloned a development branch. Unfortunately I didn't find the version number.
  2. Followed this instruction. It didn't help me. CMake didn't configured.
  3. Then I tried this video instruction with the copy-past "Full" folder trick.
  4. Run CMake.
  5. Made a configuration and generation succesfully(but with lot of "not found" and "failed").
  6. Compiled in VS 2017 succesfully. But it didn't run because of exceptions.
  7. Realized that I didn't install DirectX Software Development Kit - DXSDK_Jun10.exe.
  8. Installed it.
  9. Deleted folder with a project.
  10. Made copy-past "Full" folder trick again.
  11. Run CMake.
  12. Made a configuration and generation succesfully(with a much less "not found" and "failed" at this time!).

    Code: Select all

    Selecting Windows SDK version 10.0.16299.0 to target Windows 6.1.7601. The C compiler identification is MSVC 19.12.25835.0 The CXX compiler identification is MSVC 19.12.25835.0 Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.12.25827/bin/Hostx86/x64/cl.exe Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.12.25827/bin/Hostx86/x64/cl.exe -- works Detecting C compiler ABI info Detecting C compiler ABI info - done Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.12.25827/bin/Hostx86/x64/cl.exe Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.12.25827/bin/Hostx86/x64/cl.exe -- works Detecting CXX compiler ABI info Detecting CXX compiler ABI info - done Detecting CXX compile features Detecting CXX compile features - done Looking for sys/types.h Looking for sys/types.h - found Looking for stdint.h Looking for stdint.h - found Looking for stddef.h Looking for stddef.h - found Check size of long Check size of long - done Check size of long long Check size of long long - done Performing Test HAVE_STD_C11 Performing Test HAVE_STD_C11 - Failed Performing Test HAVE_STD_C99 Performing Test HAVE_STD_C99 - Failed Checking _FILE_OFFSET_BITS for large files Checking _FILE_OFFSET_BITS for large files - not needed Performing Test HAVE_RESTRICT Performing Test HAVE_RESTRICT - Failed Performing Test HAVE_INLINE Performing Test HAVE_INLINE - Success Performing Test HAVE_STRUCT_TIMESPEC Performing Test HAVE_STRUCT_TIMESPEC - Success Performing Test HAVE_LIBATOMIC Performing Test HAVE_LIBATOMIC - Failed Performing Test HAVE_C99_VLA Performing Test HAVE_C99_VLA - Failed Performing Test HAVE_C99_BOOL Performing Test HAVE_C99_BOOL - Success Performing Test HAVE_C11_STATIC_ASSERT Performing Test HAVE_C11_STATIC_ASSERT - Failed Performing Test HAVE_C11_ALIGNAS Performing Test HAVE_C11_ALIGNAS - Failed Performing Test HAVE_C11_ATOMIC Performing Test HAVE_C11_ATOMIC - Failed Using DirectX SDK directory: C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)/ Performing Test HAVE_GCC_FORMAT Performing Test HAVE_GCC_FORMAT - Failed Looking for stdbool.h Looking for stdbool.h - found Looking for stdalign.h Looking for stdalign.h - not found Looking for malloc.h Looking for malloc.h - found Looking for dirent.h Looking for dirent.h - not found Looking for strings.h Looking for strings.h - not found Looking for cpuid.h Looking for cpuid.h - not found Looking for intrin.h Looking for intrin.h - found Looking for sys/sysconf.h Looking for sys/sysconf.h - not found Looking for fenv.h Looking for fenv.h - found Looking for float.h Looking for float.h - found Looking for ieeefp.h Looking for ieeefp.h - not found Looking for guiddef.h Looking for guiddef.h - found Looking for pow in m Looking for pow in m - not found Looking for dlopen in dl Looking for dlopen in dl - not found Looking for dlfcn.h Looking for dlfcn.h - not found Performing Test HAVE_CPUID_INTRINSIC Performing Test HAVE_CPUID_INTRINSIC - Success Looking for aligned_alloc Looking for aligned_alloc - not found Looking for posix_memalign Looking for posix_memalign - not found Looking for _aligned_malloc Looking for _aligned_malloc - found Looking for lrintf Looking for lrintf - found Looking for modff Looking for modff - found Looking for alloca Looking for alloca - found Looking for _controlfp Looking for _controlfp - found Looking for __control87_2 Looking for __control87_2 - not found Looking for stat Looking for stat - found Looking for strtof Looking for strtof - found Looking for strcasecmp Looking for strcasecmp - not found Looking for _stricmp Looking for _stricmp - found Looking for strncasecmp Looking for strncasecmp - not found Looking for _strnicmp Looking for _strnicmp - found Looking for strnlen Looking for strnlen - found Looking for snprintf Looking for snprintf - found Looking for isfinite Looking for isfinite - found Looking for isnan Looking for isnan - found Looking for windows.h Looking for windows.h - found Looking for xmmintrin.h Looking for xmmintrin.h - found Looking for emmintrin.h Looking for emmintrin.h - found Looking for pmmintrin.h Looking for pmmintrin.h - found Looking for smmintrin.h Looking for smmintrin.h - found Looking for arm_neon.h Looking for arm_neon.h - not found Could NOT find ALSA (missing: ALSA_LIBRARY ALSA_INCLUDE_DIR) Could NOT find OSS (missing: OSS_INCLUDE_DIR) Could NOT find AudioIO (missing: AUDIOIO_INCLUDE_DIR) Could NOT find SoundIO (missing: SOUNDIO_LIBRARY SOUNDIO_INCLUDE_DIR) Could NOT find QSA (missing: QSA_LIBRARY QSA_INCLUDE_DIR) Looking for include files windows.h, mmsystem.h Looking for include files windows.h, mmsystem.h - found Looking for waveOutOpen in winmm Looking for waveOutOpen in winmm - found Found DSound: C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)/lib/x86/dsound.lib Looking for mmdeviceapi.h Looking for mmdeviceapi.h - found Could NOT find PortAudio (missing: PORTAUDIO_LIBRARY PORTAUDIO_INCLUDE_DIR) Could NOT find PulseAudio (missing: PULSEAUDIO_LIBRARY PULSEAUDIO_INCLUDE_DIR) Could NOT find JACK (missing: JACK_LIBRARY JACK_INCLUDE_DIR) Looking for include files SLES/OpenSLES.h, SLES/OpenSLES_Android.h Looking for include files SLES/OpenSLES.h, SLES/OpenSLES_Android.h - not found Building OpenAL with support for the following backends: WinMM, DirectSound, MMDevApi, WaveFile, Null Building with support for CPU extensions: Default, SSE, SSE2, SSE3, SSE4.1 Looking for include file inttypes.h Looking for include file inttypes.h - found Looking for include file stdint.h Looking for include file stdint.h - found Looking for include file sys/types.h Looking for include file sys/types.h - found Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) 0.4.1 :: 4 :: 1 :: 4 :: 2.0 Performing Test HAVE_WIN32_CC Performing Test HAVE_WIN32_CC - Success Performing Test HAVE_XINPUT_H Performing Test HAVE_XINPUT_H - Success Looking for d3d9.h Looking for d3d9.h - found Looking for d3d11_1.h Looking for d3d11_1.h - found Looking for ddraw.h Looking for ddraw.h - found Looking for dsound.h Looking for dsound.h - found Looking for dinput.h Looking for dinput.h - found Looking for xaudio2.h Looking for xaudio2.h - not found Looking for dxgi.h Looking for dxgi.h - found SDL2 was configured with the following options: Platform: Windows-6.1.7601 64-bit: TRUE Compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.12.25827/bin/Hostx86/x64/cl.exe Subsystems: Atomic: ON Audio: ON Video: ON Render: ON Events: ON Joystick: ON Haptic: ON Power: ON Threads: ON Timers: ON File: ON Loadso: ON CPUinfo: ON Filesystem: ON Dlopen: ON Options: 3DNOW (Wanted: ON): OFF ALSA (Wanted: OFF): OFF ALSA_SHARED (Wanted: OFF): OFF ALTIVEC (Wanted: ON): OFF ARTS (Wanted: OFF): OFF ARTS_SHARED (Wanted: OFF): OFF ASSEMBLY (Wanted: ON): OFF ASSERTIONS (Wanted: auto): auto CLOCK_GETTIME (Wanted: OFF): OFF DIRECTFB_SHARED (Wanted: OFF): OFF DIRECTX (Wanted: ON): ON DISKAUDIO (Wanted: ON): ON DUMMYAUDIO (Wanted: ON): ON ESD (Wanted: OFF): OFF ESD_SHARED (Wanted: OFF): OFF FUSIONSOUND (Wanted: OFF): OFF FUSIONSOUND_SHARED (Wanted: OFF): OFF GCC_ATOMICS (Wanted: OFF): OFF INPUT_TSLIB (Wanted: OFF): OFF LIBC (Wanted: OFF): OFF MIR_SHARED (Wanted: OFF): OFF MMX (Wanted: ON): OFF NAS (Wanted: OFF): OFF NAS_SHARED (Wanted: OFF): OFF OSS (Wanted: OFF): OFF PTHREADS (Wanted: OFF): OFF PTHREADS_SEM (Wanted: OFF): OFF PULSEAUDIO (Wanted: OFF): OFF PULSEAUDIO_SHARED (Wanted: OFF): OFF RENDER_D3D (Wanted: ON): ON RPATH (Wanted: OFF): OFF SDL_DLOPEN (Wanted: ON): OFF SDL_STATIC_PIC (Wanted: OFF): OFF SNDIO (Wanted: OFF): OFF SSE (Wanted: ON): ON SSE2 (Wanted: ON): ON SSEMATH (Wanted: ON): OFF VIDEO_COCOA (Wanted: OFF): OFF VIDEO_DIRECTFB (Wanted: OFF): OFF VIDEO_DUMMY (Wanted: ON): ON VIDEO_MIR (Wanted: OFF): OFF VIDEO_OPENGL (Wanted: ON): ON VIDEO_OPENGLES (Wanted: ON): ON VIDEO_RPI (Wanted: OFF): OFF VIDEO_VIVANTE (Wanted: OFF): OFF VIDEO_WAYLAND (Wanted: OFF): OFF VIDEO_WAYLAND_QT_TOUCH (Wanted: OFF): OFF VIDEO_X11 (Wanted: OFF): OFF VIDEO_X11_XCURSOR (Wanted: OFF): OFF VIDEO_X11_XINERAMA (Wanted: OFF): OFF VIDEO_X11_XINPUT (Wanted: OFF): OFF VIDEO_X11_XRANDR (Wanted: OFF): OFF VIDEO_X11_XSCRNSAVER (Wanted: OFF): OFF VIDEO_X11_XSHAPE (Wanted: OFF): OFF VIDEO_X11_XVM (Wanted: OFF): OFF WAYLAND_SHARED (Wanted: OFF): OFF X11_SHARED (Wanted: OFF): OFF CFLAGS: /DWIN32 /D_WINDOWS /W3 /DWIN32 /D_WINDOWS /W3 /GR /EHsc -DUNICODE -D_UNICODE -D_CRT_SECURE_NO_WARNINGS /MP /O2 /Ob2 /Oi /Ot /Oy /GT /Zi /W4 /nologo /GF /EHsc /GS- /Gy- /Qpar- /fp:precise /fp:except- /GR /Zc:wchar_t- EXTRA_CFLAGS: EXTRA_LDFLAGS: EXTRA_LIBS: user32;gdi32;winmm;imm32;ole32;oleaut32;version;uuid;dinput8 Build Shared Library: ON Build Static Library: OFF writing E:/Torque3D/Torque3D/My Projects/newFull/source/torqueConfig.h Prepare Template(Full) install... Configuring done
    Image
  13. Compiled in VS 2017.
  14. Run. Falid because of exceptions again.
Could you tell me what did I do wrong?

Thank you for help!
Azaezel
Posts: 395
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Sun Feb 25, 2018 6:53 am
[*] Cloned a development branch. Unfortunately I didn't find the version number.
We don't really assign point-release numbers to the dev fork, since while stuff gets tested, things can creep in we missed, so that's considered unstable till a full-bore review phase towards the end of each release-cycle. You'd want the master branch for a largely guaranteed build.
[*] Followed this instruction. It didn't help me. CMake didn't configured.
please elaborate at what point it failed to configure.
[*] Then I tried this video instruction with the copy-past "Full" folder trick.
copy-past "Full" folder trick???
[*] Made a configuration and generation succesfully(but with lot of "not found" and "failed").
most of that will be SDL seeing what all files are relevant to your setup, as reflected in the log you posted. wouldn't necessarily worry about that.
[*] Compiled in VS 2017 succesfully. But it didn't run because of exceptions.
such as? Did you build the INSTALL project after compiling? that should clone the full directory into your working dir with modifications relevant to your project, like making a main.cs alongside your exe with a bit of tweaking to reflect your game name.
[*] Realized that I didn't install DirectX Software Development Kit - DXSDK_Jun10.exe.
[*] Installed it.
should be no longer needed in the current development fork, actually.
[*] Run. Falid because of exceptions again.
need a bit more info, like what exception? there may be a generated console.log file in the same directory as your built exe. if so, there's a fair possibility of an exception being logged in the text-editable file.
avovana
Posts: 13
Joined: Sun Feb 25, 2018 2:32 am
by avovana » Sun Feb 25, 2018 12:56 pm
We don't really assign point-release numbers to the dev fork, since while stuff gets tested, things can creep in we missed, so that's considered unstable till a full-bore review phase towards the end of each release-cycle. You'd want the master branch for a largely guaranteed build.
Ok. Next time(tomorrow) I'll try it.
please elaborate at what point it failed to configure.
Now all changed. At that time(first time) I used cmake rc and didn't install DirectX. So there were many failures I can not repeat now.
copy-past "Full" folder trick???
I mean:
  • coping folder named "Full" from the folder "Templates".
  • copying it to the folder "My Progects".
  • renaming it to "newFull".
  • creating "CMake" folder like this - "My Projects\newFull\buildFiles\CMake".
  • Configuring and generating CMake into that folder.
most of that will be SDL seeing what all files are relevant to your setup, as reflected in the log you posted. wouldn't necessarily worry about that.
Ok. Thanks. Now I'm a bit less woried about it :)
such as? Did you build the INSTALL project after compiling? that should clone the full directory into your working dir with modifications relevant to your project, like making a main.cs alongside your exe with a bit of tweaking to reflect your game name.
It is not so clear for me now - I mean building the engine. I can be messy. Sorry about it.
I don't understand what you say here. Can you repeat it please in a bit another way?

If you were interested about steps I did - here what I did exactly after generating in CMake:
  • Open "newFull.sln" in the "My Projects\newFull\buildFiles\CMake" folder.
  • Choosed a "Release" in the "Solution Configurator".
  • Made a right-click on the "INSTALL" in the "Solution Explorer".
  • Builded succesfully.
  • Pushed "Start debugging".
  • Got this:

    Image

    and this in the output after stop:

    Code: Select all

    'newFull.exe' (Win32): Loaded 'E:\Torque3D\Torque3D\My Projects\newFull\game\newFull.exe'. Module was built without symbols. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\ntdll.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\kernel32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\KernelBase.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\user32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\gdi32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\lpk.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\usp10.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\msvcrt.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\advapi32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\sechost.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\rpcrt4.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\winmm.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\ws2_32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\nsi.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\ole32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\shell32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\shlwapi.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\oleaut32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'E:\Torque3D\Torque3D\My Projects\newFull\game\SDL2.dll'. Module was built without symbols. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\imm32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\msctf.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\version.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\dxgi.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\dwmapi.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\d3d11.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\D3DCompiler_43.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\nvinitx.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\api-ms-win-core-synch-l1-2-0.dll'. Cannot find or open the PDB file. Input Init: 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\uxtheme.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\cryptbase.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\clbcatq.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\dinput8.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\hid.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\setupapi.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\cfgmgr32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\devobj.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\wintrust.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\crypt32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\msasn1.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\xinput1_3.dll'. Cannot find or open the PDB file. Done 'newFull.exe' (Win32): Loaded 'E:\Torque3D\Torque3D\My Projects\newFull\game\OpenAL32.dll'. Module was built without symbols. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\MMDevAPI.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\propsys.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\dsound.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\powrprof.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Program Files (x86)\Punto Switcher\pshook64.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\imagehlp.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\AudioSes.dll'. Cannot find or open the PDB file. The thread 0x2478 has exited with code 0 (0x0). DebugDrawer Enabled! GFX Init: 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\igd10umd64.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\d3dx10_40.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Unloaded 'C:\Windows\System32\d3dx10_40.dll' The thread 0x65c has exited with code 1 (0x1). The thread 0x1e60 has exited with code 1 (0x1). The thread 0x26bc has exited with code 1 (0x1). 'newFull.exe' (Win32): Unloaded 'C:\Windows\System32\igd10umd64.dll' 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\opengl32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\glu32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\ddraw.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\dciman32.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\ig4icd64.dll'. Cannot find or open the PDB file. Could not create GL context: Операция успешно завершена. Null device found Direct 3D (version 11.x) device found 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\d3d9.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\d3d8thk.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\igdumd64.dll'. Cannot find or open the PDB file. --------- Loading DIRS --------- --------- Parsing Arguments --------- 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\mswsock.dll'. Cannot find or open the PDB file. 'newFull.exe' (Win32): Loaded 'C:\Windows\System32\WSHTCPIP.DLL'. Cannot find or open the PDB file. UDP initialized on ipv4 IP:0.0.0.0:61167 Attempting to create GFX device: Intel(R) HD Graphics Family (D3D11) [] Device created, setting adapter and enumerating modes Exception thrown at 0x000000014078001C in newFull.exe: 0xC0000005: Access violation reading location 0x0000000000000000. The program '[8400] newFull.exe' has exited with code 0 (0x0).
  • Error occurred when I tried to run "newFull.exe" also.
should be no longer needed in the current development fork, actually.
Strange, because, as I said, for first time I used CMake there were many errors and I'm pretty sure that I didn't see name DirectX with some "succesfull" mark as I saw later - after installing DirectX.
need a bit more info, like what exception? there may be a generated console.log file in the same directory as your built exe. if so, there's a fair possibility of an exception being logged in the text-editable file.
Here is info from the console.log file:

Code: Select all

//-------------------------- 2/25/2018 -- 15:42:15 ----- Processor Init: Unknown x86 Compatible, ~2.29 Ghz HT detected MP detected [2 cores, 4 logical, 1 physical] Math Init: Installing Standard C extensions Installing Assembly extensions Initializing platform... Input Init: Done DebugDrawer Enabled! GFX Init: Could not create GL context: Операция успешно завершена. Null device found Direct 3D (version 11.x) device found --------- Loading DIRS --------- --------- Parsing Arguments --------- UDP initialized on ipv4 IP:0.0.0.0:61167 Attempting to create GFX device: Intel(R) HD Graphics Family (D3D11) []
Azaezel, thank you for your reply! I really appreciate your help. And I try to explain well what I did and provide all possible information that might be needed.
Timmy
Posts: 348
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Sun Feb 25, 2018 10:30 pm
Does you system have switchable graphics @
User avatar
avovana
? It looks like it is trying to init the on board Intel HD gpu & is crashing there. See if you can force the discrete card (your nvidia) to be enabled and report back what happens. Are you running that with a debug or release build? If it's a release build, recompile it again but with the debug build while we sort this problem out.
avovana
Posts: 13
Joined: Sun Feb 25, 2018 2:32 am
by avovana » Mon Feb 26, 2018 5:32 am
Does you system have switchable graphics @ avovana ?
I decided to change PC and the enviroment.

It is pretty strange but it works now!

I chose the "master" branch as was recommended.
I configured and generated with CMake v 3.8.2 for a Visual Studio 14 2015 Win64 that I have on this PC.
It was pretty interesting because there were much more items in Cmake comparing with configuring "development" branch.
I run VS2015, builded and run! And it works! :)

Thanks for help!
Timmy
Posts: 348
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Mon Feb 26, 2018 6:59 am
Does you system have switchable graphics @ avovana ?
I decided to change PC and the enviroment.

It is pretty strange but it works now!

I chose the "master" branch as was recommended.
I configured and generated with CMake v 3.8.2 for a Visual Studio 14 2015 Win64 that I have on this PC.
It was pretty interesting because there were much more items in Cmake comparing with configuring "development" branch.
I run VS2015, builded and run! And it works! :)

Thanks for help!
Ok glad it is working. Whenever you get a chance, if you could test the master branch with the original PC (the one with the nvidia & intel card) and report back that would be appreciated.
avovana
Posts: 13
Joined: Sun Feb 25, 2018 2:32 am
by avovana » Mon Feb 26, 2018 10:15 pm
I changed to "master" branch on my home PC(I desribed problem with run on this PC).
I made a project.
This time it doesn't comile! Many errors occured! So I can provide info but what kind?
Timmy
Posts: 348
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Mon Feb 26, 2018 10:56 pm
oops i forgot to mention the master branch doesn't compile with vs 2017, only the development branch will.
Johxz
Posts: 441
Joined: Sat Feb 07, 2015 11:37 pm
by Johxz » Tue Feb 27, 2018 1:24 am
hey @ avovana sorry to not get you on time, but it seems that you figure it out. Good! ;)

That tutorial need to be updated, is a little old now. I'm not using VS2017, I will keep VS2015 for a little longer, because in every new release VS it's getting slower.

But as Tim said, if you need VS2017, you need to use the development branch.
avovana
Posts: 13
Joined: Sun Feb 25, 2018 2:32 am
by avovana » Tue Feb 27, 2018 7:37 am
@
User avatar
Timmy
, thank you for this info!

@
User avatar
Johxz
, thank you for the reply! If I will go further in the gamdev industry I'll make contribution also(making tutorials or something else)!

It is a great feeling that I'm not facing a problem alone but with your, guys, help!
30 posts Page 3 of 3

Who is online

Users browsing this forum: No registered users and 2 guests