Torque 3D not starting on Ubuntu 17.10 (Open GL 1.4)

There are no stupid questions, just stupid answers.
4 posts Page 1 of 1
aunaseef
Posts: 7
Joined: Wed Mar 28, 2018 6:40 pm
by aunaseef » Wed Mar 28, 2018 9:38 pm
Initializing platform...
Input Init:
%
Failed to load OpenAL shared library. Sound will not be available
SFXALProvider - OpenAL not available.
DebugDrawer Enabled!
GFX Init:
Could not create GL context: GLXBadFBConfig
../Engine/source/gfx/gl/sdl/gfxGLDevice.sdl.cpp(95,0): {Fatal} - Could not create GL context: GLXBadFBConfig
Platform::debugBreak: triggering SIGSEGV for core dump
% Trace/breakpoint trap (core dumped)
What's wrong? I think my graphics card is too old. Will it work if I build Torque3D with an older Open GL version?
Jason Campbell
Posts: 253
Joined: Fri Feb 13, 2015 2:51 am
 
by Jason Campbell » Thu Mar 29, 2018 12:02 am
I think even 3.7(first Linux client) used opengl 3.x so, sorry, I think that your card is just too old. What is your card by the way?
JeffR
Steering Committee
Steering Committee
Posts: 813
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Thu Mar 29, 2018 2:41 am
Yeah, I'm curious what hardware you're running?
aunaseef
Posts: 7
Joined: Wed Mar 28, 2018 6:40 pm
by aunaseef » Thu Mar 29, 2018 12:13 pm
My graphics card is Intel G41 Express Chipset, Windows Version ran fine on this card.
I think I should just go back to Windows instead of messing around with Linux version, I assume Windows version uses Direct X, So It will run fine.
I can't even use Torsion in Linux.

Anyway, Thanks for replying to my post.
4 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest