Page 2 of 2

Re: 3.10 or wait for 4.0

Posted: Tue Jan 16, 2018 5:09 pm
by Duion
"I mean, people using it is how issues get corrected, so..."
Yes, that is correct, but if you want to produce something fast or you have a project that is already released and being used, I would recommend using stable and proven to work versions, otherwise yes you can just use the latest.

Re: 3.10 or wait for 4.0

Posted: Tue Jan 16, 2018 9:21 pm
by andi_s
Thanks all for the input! I just managed to compile the latest dev, without the DX sdk. Had a look at the basegame template, however in the world editor, there were none of the new components available (FpsGamePlayModule). I will play around more in the next days with dev and also with a 3.10 binary.

Re: 3.10 or wait for 4.0

Posted: Tue Jan 23, 2018 12:30 am
by Razer
Is there a daily binary available somewhere ? I would like to try 4.0

Re: 3.10 or wait for 4.0

Posted: Tue Jan 23, 2018 1:04 pm
by Duion
Is there a daily binary available somewhere ? I would like to try 4.0
There are binaries for the releases, thats all and if you really want to try in development stuff, you should be able to compile it yourself and have some knowledge what you are doing.

Re: 3.10 or wait for 4.0

Posted: Tue Jan 23, 2018 10:09 pm
by Bloodknight
waiting is almost always the wrong choice since there is always another update around the corner that you like the look of.

As far as PBR, from what I understand upgrading from current isn't a terrible path, and porting some work youve already done to a newer version is never really as difficult as most people think it is since rarely are the API changes so drastic as to make it so (unless you work on apple stuff and they depricate an entire language).

get stuck in and get prototyping, you will still learn how the engine ticks :)

Re: 3.10 or wait for 4.0

Posted: Mon Jan 29, 2018 9:14 pm
by Code_Man
Hi all.

Im in a somewhat similar boat, except i already messed with t3d a little, however i only got uebergame to work and use it as my base for now.
Building from source neither mainline t3d nor uebergame worked for me, the bug already had been reported however.

The problem is i have been trying to work with vehicles and there seem to be quite a few engine descrapencies that i would need fixed, but without being able to compile the engine properly i have no real means to test or even make proper bug reports.
Im sticking with uebergame since i got to understand it somewhat decently and it works well for me, i hope it gets to t3d 4.0 too eventually when its stable enough.
I also noticed many other minor detail things not working and or documents/examples not being up to date, though i havent investigated further.

For the time being i told myself im gonna sit things out and work on other stuff and when 4.0 is out i will see again about getting things to work.
Im not in a rush, so i can afford it.

So yeah would be good to know if i should expect a revolution with 4.0 or try hard to compile and mess with source.

Also uebergame is great, good work duion.

Re: 3.10 or wait for 4.0

Posted: Tue Jan 30, 2018 4:30 pm
by Duion
@
User avatar
Code_Man

Well I will eventually port Uebergame over to 4.0, maybe not now, but maybe for the overnext version. I aim for roughly 4 releases per year.

Regarding the compilation problems, it may help posting the issues/errors you encountered. For Uebergame-engine I also cannot compile it in debug mode, since there is an issue I was too lazy to debug, thats why you have to make a release build, don't know if that exists in the main branch as well, but I think it is from an engine change I made to support a feature in Uebergame.

Otherwise it depends what you want to do, since you only need to self compile if you are going to make engine changes and/or release your game and both cases are rare, so most people will go fine with a precompiled version first.

Re: 3.10 or wait for 4.0

Posted: Wed Jan 31, 2018 12:08 am
by Bloodknight
Im in a somewhat similar boat, except i already messed with t3d a little, however i only got uebergame to work and use it as my base for now.
Building from source neither mainline t3d nor uebergame worked for me, the bug already had been reported however.
more details are required...

Most compiler time bugs are fixed pretty quickly, afaik the only bug that ubergame shares with the main repo on the master branch is the VS2017 issue, which is fixed here -> Github PR #2039

Re: 3.10 or wait for 4.0

Posted: Mon Feb 12, 2018 1:19 pm
by Code_Man
I tried compiling a recent pull of the development branch and compile it, however i got an error.
/home/virtual/torque3d/Engine/source/T3D/components/audio/SoundComponent.h:70:7: Fehler: zusätzliche Qualifizierung »SoundComponent::Sound::« an Element »Sound« [-fpermissive]
Sound::Sound()
^~~~~
Kompilierung wegen »-Wfatal-errors« beendet.
Roughly translates to: error additional qualification on element sound.
Altough i have no idea what that means, i havent worked much with C++.
Havent yet checked if it has been reported, im on fedora 27, x64 btw.

I assume the most recent uebergame (congrats btw, really like the new maps) works on a similar version.
I checked the github fork differences, or whatever you call it and seems ueberengine is a unmodified fork of main repo or did i get that wrong?

Also i tested vehicle stuff with recent uebergame, but it fell trough the ground again, not a good way to test things.
Im not up to speed with what the situation is regarding physics, from what i heard you will be adding modular physics libraries such as bullet.
Not sure what to do in this, or even how i would debug such a thing.
Its not that im in a rush but if i could work on testing vehicles and such that would be great.

Re: 3.10 or wait for 4.0

Posted: Mon Feb 12, 2018 4:24 pm
by JeffR
Yeah, @
User avatar
Johxz
had actually come across the same bug. We've got a fix, just gotta get it rolled in. Should happen today.