Page 1 of 1

programatically adjust soundemitter volume?

Posted: Wed Jul 15, 2020 1:42 am
by fLUnKnhaXYU
hello ,
Since im here anyway with my just posted issue with turretShape , Im gonna go ahead and post this new stumbling spot . The volume control listed in the sound emitters property panel in the editor does has no affect for me . I just encountered this while hoping to reduce a profile volume ie or eg or whatever a small camp fire which sounds like a roaring inferno . I haven't studied it very deeply and I am a bit unabashedly hoping someone might have a suggestion on programatically adjusting the volume . kind of strange thing that the option is in the properties but when i use Emitter.dump it shows no options for volume get or set . to clarify , as I probably should , this means ability to use the same profile at different volumes . thank you .

Re: programatically adjust soundemitter volume?

Posted: Tue Sep 08, 2020 1:14 am
by Steve_Yorkshire
Call the volume directly rather than a function to alter the volume - which seems a bit odd but hey ...
soundEmitterID.volume=0.5;
And apologies for not mentioning this months ago ;)

Re: programatically adjust soundemitter volume?

Posted: Tue Sep 08, 2020 5:36 am
by fLUnKnhaXYU
certainly no apology necessary and thank you for your time Steve .

Re: programatically adjust soundemitter volume?

Posted: Wed Sep 23, 2020 6:04 am
by fLUnKnhaXYU
that didn't work for me . Would it make any difference to mention I'm using ver 3.9 and I haven't tried your suggestion on 3.10 with which I usually have more luck with audio .

Re: programatically adjust soundemitter volume?

Posted: Wed Sep 23, 2020 12:34 pm
by Duion
I never noticed audio things being changed in any update.

Re: programatically adjust soundemitter volume?

Posted: Thu Sep 24, 2020 5:55 am
by fLUnKnhaXYU
Duion , I don't remember exactly the issue/s but choosing the openAL required a little editing of the preferences file , if I recall correctly . I wont say I didnt screw it up myself with a openALsoft driver or one of my haphazard approaches to who knows but I was left with the impression 3.10 was somehow stabler . At least I, f I recall correctly , the openAl driver was an available option . Sorry Ill not be able to answer any technical questions , ok? I will be getting back to some audio adventures though , eventually . Thank you .