3.8 vs 3.9 performance tests

Materials, textures, lighting, postfx
3 posts Page 1 of 1
Duion
Posts: 757
Joined: Sun Feb 08, 2015 1:51 am
 
  by Duion » Thu Aug 11, 2016 7:38 pm
I thought I start a thread to collect some data regarding performance in the latest update

First I thought the performance was better, but after I did a test, it actually was kind of exactly the same.

Here a screenshot in 3.8 ( Uebergame 1.0.6.0 )

http://duion.com/files/temp/screenshot_010-00000.png

And here in 3.9 ( Uebergame latest development branch )

http://duion.com/files/temp/screenshot_ ... -00000.png

Both screenshots were at max graphic settings, you notice the polycount is halved in 3.9 and the drawcallcount even less than half now, but no FPS increase.
Of course the FPS were fluctuating between like 49 and 59 or so, but most of the time it was between 53 and 57, never over 60 and the worst lag spikes occasionally brought it down to 45, but it was relatively rare. It is the same scene but in the 3.9 screenshot I updated the basetexture and fog to be more sand colored.
I also used the new shadow caching with setting up only my play and weapon models to use dynamic lighting and the rest I set down to 128ms ( 250 the default setting was too high, you could see shadows popping all the time)
So in that scene I could not notice performance gain so far, maybe other new issues counteract this, like double sided terrain materials: https://github.com/GarageGames/Torque3D/issues/1727
Duion
Posts: 757
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Thu Aug 11, 2016 7:56 pm
Another test on TG_Fields map

3.8:

http://duion.com/files/temp/screenshot_011-00002.png

3.9

http://duion.com/files/temp/screenshot_ ... -00003.png

As you can see you have more FPS in the 3.9 screenshot now. The frames tended to be around 60 in the 3.8 shot and around 70 in the second 3.9 shot.
You can see drastically reduced poly and drawcall count, but this may not be accurate as the LOD system was messed up and it is much more aggressive in 3.9 so this probably is one of the reasons for lower polygon count and may make up for much of the FPS gain.

I think accurate comparisons are a bit complicated in many cases, since the terrain has backfaces which probably reduce some performance and the LOD system is more aggressive which increases performance. You could try a scene without terrain and without models that have LOD stages maybe.
Nils
Posts: 160
Joined: Thu Feb 05, 2015 3:32 am
 
by Nils » Sat Aug 13, 2016 3:02 pm
Thanks for sharing @
User avatar
Duion
3 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest