3.9 ambient scale and brightness

Materials, textures, lighting, postfx
  • 1
  • 2
17 posts Page 1 of 2
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
  by Duion » Mon Aug 08, 2016 3:25 am
I noticed the ambient colors in 3.9 being overall much brighter. Before 3.9 it was like that 100% bright was 100% bright, 50% bright was 50% bright and 0% was 0% bright, now it feels more like the algorithm works different and 50% bright is more like 85% bright and 25% is like 70% bright etc.
What I want to say is that if you want to work with dark scenes like night, you only have like the lower 10% of the brightness scale to work with, since everything else is too bright and the scale is too small to being able to adjust it well through the slider.
Like if you want night brightness levels you now have to use values from 0.05 to 0.00 now.
For example in one scene before I had for night ambient the value 0.2 and now I have to go down to like 0.025 to 0.035 to have a similar result, you cannot even enter such small numbers in the editor, you can enter only two digits after the comma, you can only hope to hit it with the mouse slider. Overall it looks like you have to go down to almost 10 times lower to achieve a similar result now.
So it seems some algorithms have changed like the ambient scale as well as brightness and gamma, which now work differently, since you have brightness, contrast in addition to gamma and gamma only works in a small range now from 2 to 2.5 above and below it will not do anything.

So any ideas what has been going on to the algorithms and rendering? I don't necessarily want it changed, but at least the color picker menu needs some change either to be able to pick the colors better and more accurate or bringing the algorithm up so you can use the proper range.
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Tue Aug 09, 2016 8:28 pm
I made a comparison screenshot of the same scene with same lighting settings in scatterSky, one in 3.8 and one in 3.9 with the new deferred rendering.

The settings are:
night color: 0.2
fog color: 0
moonlight color: 0.3

3.8: http://duion.com/files/temp/screenshot_005-00002.png

3.9: http://duion.com/files/temp/screenshot_ ... -00002.png

As you can notice the new version is extremely more bright with the same settings.

PS: You can also see that the black fog, does not darken anymore in 3.9.

PPS: The first screenshot in 3.8 had HDR turned off, that is why the colors are more saturated, but for the brightness it does not alter much, since HDR actually darkens the scene and in 3.9 where it is on, it is still much brighter.
Last edited by Duion on Tue Aug 09, 2016 9:15 pm, edited 1 time in total.
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Tue Aug 09, 2016 8:35 pm
Being able to pick smaller numbers may not be a solution since the one color picker cannot go lower:
0.024 is #060606 and next step is 0.027 which is #070707 and inbetween there is none, that is already the smallest steps you can go.
So you are only left with a handful of brightness steps where you can adjust night ambience.
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Tue Aug 09, 2016 8:51 pm
This may be related to the fog banding issue https://github.com/GarageGames/Torque3D/issues/1724
Since when I adjusted the lighting settings to more extreme numbers in 3.8 the fog banding became visible as well, it depends on lighting and contrast to make the banding visible and since you have to use more extreme values in 3.9 this may be the reason the fog banding becomes visible more.
NekoDemon117
Posts: 35
Joined: Thu Feb 19, 2015 1:09 pm
by NekoDemon117 » Wed Aug 10, 2016 4:57 am
I think this is because of the fog banding issue.

I discovered fog artifacts (auras) in the sky in the "Outpost" level. What I did was change the day/night cycle setting to night and turn off the "play" setting. Then I went up into the "bridge" part of the building. Then when I look up at the sky after looking down at the bridge, the sky has flickering auras that quickly dissipate. This is infinitely repeatable by looking back down at the bridge, then looking back up at the sky.

I can't really show the problem properly with a screenshot, but I could show exactly what I mean if I could get a video recording. Is there a built-in video capture in Torque3D?


Also, the ground is still very dark, but the sky looks a lot brighter than it should and some places in the map are lit up weird.
JeffR
Steering Committee
Steering Committee
Posts: 757
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Wed Aug 10, 2016 11:55 pm
@
User avatar
NekoDemon117


Try Bandicam. Free, and it produces pretty solid quality videos without a huge amount of recording overhead. I use it and it's pretty solid.

OT, As per the work that went on in IRC yesterday, it looks like most of this stems from how linearization of light and colors was being handled. Good headway was made on that, and we can get the code up here for others to verify against before a roll-in. I think the only remaining bit is the fog was still a touch off, but overall the lighting was much improved and correct.
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Thu Aug 11, 2016 2:05 am
Please do not use Bandicam it mutilates your videos with a branding use https://obsproject.com/ instead.
And Torque has a build in movie recorder as well.

Regarding the issue, yes the code fixes the ambient scale, but the fog, the specular and the backside of the objects may still be wrong.

3.8:
http://duion.com/files/temp/screenshot_007-00002.png

3.9 with fix:

http://duion.com/files/temp/screenshot_ ... -00000.png

Here another shot with the Soldier using the same skin, since it uses a darker skin on my first picture.

http://duion.com/files/temp/screenshot_ ... -00000.png

As you can see, fog is too bright and the backside of the soldier is too dark, the specular thing you cannot see much in that screenshot.
Settings are 0.2 ambient, 0.3 moonlight color and 0.1 fog color.
Last edited by Duion on Thu Aug 11, 2016 11:04 pm, edited 2 times in total.
Duion
Posts: 833
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Thu Aug 11, 2016 3:11 pm
And before someone says my specular maps are adjusted wrong, they cannot be adjusted at the moment, since that system is broken.
There is probably a chain reaction of issues since the light colors are wrong to begin with.
Azaezel
Posts: 384
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Thu Aug 11, 2016 3:55 pm
https://github.com/Azaezel/Torque3D/com ... d9aef7dd01 the code we were going over regarding ambient.
Nils
Posts: 160
Joined: Thu Feb 05, 2015 3:32 am
 
by Nils » Thu Aug 11, 2016 5:21 pm
If you have a recent NVIDIA GPU then simply use Shadowplay for recording. There's much less performance drop with that.

@
User avatar
Duion
The differences shots look worrisome. Even the normal maps seem to be completely off.
Are $pref::Video::Contrast, $pref::Video::Brightness and $pref::Video::Gamma properly set? (those are implemented with 3.9, right?)

May I ask what difference in performance you see between 3.8 and 3.9?
  • 1
  • 2
17 posts Page 1 of 2

Who is online

Users browsing this forum: No registered users and 2 guests