Replace Epoxy with Glad

This forum is for tracking and working on active issues that need to be resolved, as well as testing Pull Requests that are waiting to be integrated into Torque 3D.
6 posts Page 1 of 1
JeffR
Steering Committee
Steering Committee
Posts: 750
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Thu Sep 29, 2016 7:46 pm
Pull Request: https://github.com/GarageGames/Torque3D/pull/1766

While Epoxy's proven it can work better than glew, it looks like it's older and not supported compared to Glad, so we're looking at swapping over to Glad for the OpenGL extension tracking and the like. Grab it, fire it up on OpenGL and note any issues or errors as well as your hardware config so we can see if there are any hardware/driver issues that'd cause a problem.
Johxz
Posts: 411
Joined: Sat Feb 07, 2015 11:37 pm
by Johxz » Thu Sep 29, 2016 7:53 pm
thank you Jeff I will test it this weekend.
Johxz
Posts: 411
Joined: Sat Feb 07, 2015 11:37 pm
by Johxz » Sat Oct 01, 2016 8:11 pm
@
User avatar
JeffR


I only see problem with the trees

Image

Video 1
Video 2
Video 3
JeffR
Steering Committee
Steering Committee
Posts: 750
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Mon Oct 03, 2016 3:38 pm
Do you see that with the current epoxy as well? We'd noted that there's some sort of issue with the rendering/clipping on imposters in GL before, just hadn't tracked it down yet.
Azaezel
Posts: 383
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Mon Oct 03, 2016 6:07 pm
JeffR wrote:Do you see that with the current epoxy as well? We'd noted that there's some sort of issue with the rendering/clipping on imposters in GL before, just hadn't tracked it down yet.


And grass. Basically, anything that'll call fizzle. Still tracking on that.
Johxz
Posts: 411
Joined: Sat Feb 07, 2015 11:37 pm
by Johxz » Tue Oct 04, 2016 4:13 am
aahmmm yeah :oops: v3.8 have this issue with the trees. But in v3.9 it is very noticeable.
6 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest