Pre-Pull Request: Deferred Shading

This forum is for tracking and working on active issues that need to be resolved, as well as testing Pull Requests that are waiting to be integrated into Torque 3D.
23 posts Page 2 of 3
razvanab
Posts: 18
Joined: Tue Jul 07, 2015 8:02 pm
by razvanab » Tue Jan 19, 2016 6:32 pm
JeffR wrote:@razvanab
Az means that in the Deferred_Complete_3.8 branch that we'll be testing to make sure the Deferred stuff is ready, he's merged in those OpenGL fixes that Lopuska made.

Once this branch has been sufficiently tested though, yes, it will be PR'd and rolled into the main repository. So, if you'd like to see that happen sooner, feel free to grab it and do some testing :)


I already did that and so far it looks good. But I noticed some bugs on the water planes when I enable some post_fx for example bloom.
Are there some deferred specific bugs that I should be looking for?
Azaezel
Posts: 383
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Tue Jan 19, 2016 9:18 pm
saindd wrote:Won't deferred shading make the engine much slower?

Prepass Lighting (advanced) is a deferred variant. Only major difference is we don't throw buffers out between prepass then multiply on diffuse.

razvanab wrote:But I noticed some bugs on the water planes when I enable some post_fx for example bloom.
Are there some deferred specific bugs that I should be looking for?


Image
Timmy
Posts: 307
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Tue Jan 19, 2016 10:43 pm
saindd wrote:Won't deferred shading make the engine much slower?


Depending on your scene and hardware configuration, deferred shading can be faster than Prepass Lighting. While it certainly uses more bandwidth it also avoids rendering everything twice.
Azaezel
Posts: 383
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Tue Jan 19, 2016 10:43 pm
Looks like stock, bloom was never getting applied in the first place: http://imgur.com/a/gsIOg this one'll likely be a bit tricky.
razvanab
Posts: 18
Joined: Tue Jul 07, 2015 8:02 pm
by razvanab » Tue Jan 19, 2016 11:11 pm
@
User avatar
Azaezel

That crack me up.
Azaezel
Posts: 383
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Tue Jan 19, 2016 11:16 pm
http://imgur.com/a/krd8g that work for folks?
razvanab
Posts: 18
Joined: Tue Jul 07, 2015 8:02 pm
by razvanab » Wed Jan 20, 2016 12:10 am
Azaezel wrote:http://imgur.com/a/krd8g that work for folks?

It looks good to me.
Azaezel
Posts: 383
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Wed Jan 20, 2016 12:22 am
JeffR
Steering Committee
Steering Committee
Posts: 740
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Mon Jan 25, 2016 9:09 pm
Did some testing on that here. Does indeed add the bloom back in, but it looks like the bloom is on even at night time in the Outpost level. Probably an artifact of how specularity is calculated on the water than anything else though.

Otherwise, seems like a solid fix. Anyone else noting any other problems? Because if not, this'll probably get rolled in in the next couple days if no one elses spots any issues.
newaged
Posts: 31
Joined: Sat Feb 14, 2015 12:27 am
by newaged » Wed Jan 27, 2016 8:52 pm
What changes do you need to make to custom materials / shaders that worked in 3.8 to get them to work here? They are always replaced with a white mat in the deferred branch. Can't share the shader code, I didn't write it.
Last edited by newaged on Thu Jan 28, 2016 9:34 pm, edited 1 time in total.
23 posts Page 2 of 3

Who is online

Users browsing this forum: No registered users and 1 guest