Holes in terrain not working

Friendly conversations, and everything that doesn't fit into the other forums.
  • 1
  • 2
16 posts Page 2 of 2
Mitovo
Posts: 65
Joined: Sun Apr 12, 2015 5:46 pm
by Mitovo » Tue Dec 20, 2016 12:27 am
For those asking,

I'm using Bullet Physics, and OpenGL rendering, and I'm using 3.8 (can't seem to get 3.9 to work right).

But really, should the physics version really matter? I'd imagine the terrain system would be programmed to recognize when a part of its surface has been set to "empty", regardless.
RasterRon
Posts: 53
Joined: Sun Oct 25, 2015 7:36 am
 
  by RasterRon » Tue Dec 20, 2016 1:17 am
MiToVo wrote:I'm using Bullet Physics, and OpenGL rendering, and I'm using 3.8 (can't seem to get 3.9 to work right).


Great, looks like it is Bullet specific as Duion also reported. I tested the same floating result with 3.8.
Timmy
Posts: 238
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Tue Dec 20, 2016 6:13 am
So peeps know this is a bullet only thing, i believe @
User avatar
JeffR
is chucking up a fix soonish, if he doesn't get the time or whatever i'll chuck up the fix.
JeffR
Steering Committee
Steering Committee
Posts: 682
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Tue Dec 20, 2016 7:11 am
Hey guys, try this and test 'er out. Seemed like it worked for me.

https://github.com/GarageGames/Torque3D/pull/1876.

Credit goes to @
User avatar
Lopuska
from his PhysicsGMKRefactor work, and Az and Timmy for remembering about it ;)

MiToVo wrote:For those asking,
But really, should the physics version really matter? I'd imagine the terrain system would be programmed to recognize when a part of its surface has been set to "empty", regardless.


The setup passes through the physics abstraction layer on to the physics library in question. The issue was that the abstraction part didn't properly translate the holes in such a way for bullet to know about all that. the stock and physx stuff happened to. The above code change should make bullet properly aware of holes in the terrain, so give it a shot and let me know :)
RasterRon
Posts: 53
Joined: Sun Oct 25, 2015 7:36 am
 
by RasterRon » Tue Dec 20, 2016 1:47 pm
Awesome, working great now! :)
Mitovo
Posts: 65
Joined: Sun Apr 12, 2015 5:46 pm
by Mitovo » Tue Dec 20, 2016 9:17 pm
Well that's a first. I actually posted something useful!

:p

I'll have to check it out later after work.

Thanks!
  • 1
  • 2
16 posts Page 2 of 2

Who is online

Users browsing this forum: No registered users and 1 guest