Blending mode for terrain materials....

Friendly conversations, and everything that doesn't fit into the other forums.
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10
93 posts Page 10 of 10
Mitovo
Posts: 85
Joined: Sun Apr 12, 2015 5:46 pm
by Mitovo » Wed Aug 09, 2017 7:19 pm
Duion wrote:Life is Feudal does not have that good terrains, they are kind of mediocre and the textures as well. The thing with Life is Feudal is, that the Terrain can be modified ingame as well as all the other stuff, therefore you cannot enhance it artistically by hand. If you use baked basetextures for the whole terrain and high res textures you can even achieve much better results than Life is Feudal. Look at BeamNG they have much nicer terrains, but it all depends on scene.


Let no opinion go unchallenged, eh Duion? lol I wasn't claiming they were the "best ever". I didn't say they were better or worse than anything else. I was just saying "I think the terrain materials in LiF look great, so I know that kind of result is possible", relative to the trouble I was having with it in 3.10.

As for the halo thing around texture layers.. yeah it's kinda unsightly. Hopefully that can be somehow addressed.

In the meantime, I think you can do quite a bit with 3 texture layers. Just have to be more "creative" with it.
Duion
Posts: 812
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Wed Aug 09, 2017 9:14 pm
I was just saying that LiF terrains are just average, anyone can do that with T3D, the rest is just other settings and graphical features like ambience light, postFX, shaders etc.

The "halo" thing is not that bad, I easily use around 5-10 layers per map, it is hardly noticeable, so by far not a reason to not use more layers.
LukasPJ
Site Admin
Posts: 348
Joined: Tue Feb 03, 2015 7:25 pm
 
by LukasPJ » Thu Sep 07, 2017 9:54 pm
For the record, yes the blending was broken with more than 3 textures, this has been an issue throughout the lifetime of T3D. It has to do with the blending between different passes over each terrain block.

I've tried to fix it numerous times, but there is always a new issue showing up.

My latest attempt to fix this issue is this PR: https://github.com/GarageGames/Torque3D/pull/2049 but it doesn't work in OpenGL. It should be fixed if I figure out how to get the constNum of textures, as I'm doing some hackery around that, which is unstable.


The reason the colours are off, is due to the change to working with colours in "linear space". CryEngine encountered the same issue, they fixed it by moving the terrain color back into whatever space it was before ( I'm not fully versed in these things :P ). With that change the terrain colours would give you the same results as before linear space. Giving you less "correct" colours, but an easier pipeline. An example of that can be seen in this issue: https://github.com/GarageGames/Torque3D/issues/2050

This is the reason why no one minded the terrain textures in 3.8, but are having difficulties working with them in 3.9/3.10.
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10
93 posts Page 10 of 10

Who is online

Users browsing this forum: No registered users and 5 guests