WorldMachine pipeline

Level design, models, animations, physics, etc.
25 posts Page 1 of 3
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Sat Jun 06, 2015 1:25 am
I'm curious about your pipeline with WorldMachine. I'm currently using this macro to export my splatmaps:

http://www.world-machine.com/library/in ... nt&focus=1

However, my terrains look like shit with a lot of patterns in the textures, even when using details. How do you guys make such nice terrains (that i see i many T3D screens)? :)
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Sat Jun 06, 2015 1:59 am
I have exported a 2048x2048 PNG heightmap from WorldMachine and also a splatmap. However, the terrain looks like crap:

http://imgur.com/m8QAmNx

Any ideas?
Duion
Posts: 670
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Sat Jun 06, 2015 3:43 am
The base texture does not look like its applied correctly. You need to apply the splat map as base texture in your materials, or overwrite the yourterrain_basetex.dds with it.
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Sat Jun 06, 2015 5:16 am
Not only the texture, but look at the triangles. The generated mesh is very low poly.
Duion
Posts: 670
Joined: Sun Feb 08, 2015 1:51 am
 
by Duion » Sat Jun 06, 2015 11:48 am
The terrain is pretty high poly, you have to live with it and smooth the terrain, you can increase terrain resolution but this is not practical, it will give far too many polys.
LukasPJ
Site Admin
Posts: 316
Joined: Tue Feb 03, 2015 7:25 pm
 
by LukasPJ » Sat Jun 06, 2015 2:18 pm
@
User avatar
saindd
when WorldMachine generates a terrain, it does so for a terrain that's typically designed to look good at a distance (at least, I know this is the case for World Creator). So, therefore you have to adjust, and smooth out the close-up detail as Duion suggested, such that the terrain becomes playable.

The reason for this is that WorldMachine aims for realism, and realistically a terrain has almost infinite detail, however we have a limited budget for rendering our terrain and have to limit the resolution of our terrain. Therefore, you typically don't have a lot of detail up close (but you do have some ofc), and then for that fine up-close detail, you use rock models and foliage.

As for the splat-map, it looks odd. You may have to turn it upside-down, can't remember if that were fixed. I made tutorial for exporting from WorldCreator to Torque3D perhaps, some of it could help you do the same for World Machine.

Edit: also remember that out-of-the-box Torque3D is set to pretty low graphics settings, the shadow you see in your screenshot is therefore of a very low resolution (but looks fine up-close) you could turn up the visible-distance of the high-resolution version of this shadow, to get a better idea of how your terrain actually looks.
Edit Edit: This is also true for the resolution of the terrain itself.
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Sat Jun 06, 2015 4:02 pm
How can you increase terrain resolution? Or the shadow resolution? When i try to smooth the terrain, the tools end up adding even more triangles, with terrible shadowing results.
LukasPJ
Site Admin
Posts: 316
Joined: Tue Feb 03, 2015 7:25 pm
 
by LukasPJ » Sat Jun 06, 2015 4:52 pm
saindd wrote:How can you increase terrain resolution? Or the shadow resolution? When i try to smooth the terrain, the tools end up adding even more triangles, with terrible shadowing results.

There is no tool that "adds triangles".. There is a fixed amount of triangles, what you can do, is change the LoD settings, such that there you push away the distance at which the terrain loses quality.

Shadow resolution, I believe is a property on the sun or scattersky object. Can't remember though, maybe someone else can pitch in here?
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Sat Jun 06, 2015 5:05 pm
Not adding triangles, i expressed myself badly. I mean the smooth tool: when i apply it to the terrain, i get an even worse look, with lot's of unaligned triangles in the terrain and bad shadowing. Not really smoothing the damn thing. I'm pretty sure this is a resolution problem, but still, i'm using a 2048x2048 heightmap with 1 meter per pixel config. Should i be using 4092 instead? Will it work outside 64-bit builds?
LukasPJ
Site Admin
Posts: 316
Joined: Tue Feb 03, 2015 7:25 pm
 
by LukasPJ » Sat Jun 06, 2015 5:42 pm
I usually use 2048x2048 and get fine results from it, I don't know what triggers your issues, can you screenshot it?

IIRC it smooths relative to the other vertices selected by the tool, try using a bigger brush, can't tell for sure what you're actually doing though.

Edit: btw, increasing geometry resolution probably doesn't help on your shadow results. The shadowmap has its own resolution.
25 posts Page 1 of 3

Who is online

Users browsing this forum: No registered users and 1 guest