Page 4 of 4

Re: Torque 3D 3.10 Released!

Posted: Thu Mar 30, 2017 3:46 pm
by JeffR
Yeah, related but not quite the same. When I downloaded the binary, it threw the 'unidentified developer' shindig (pretty sure it's purely a signing issue, not "other machine cooties" in this particular case because I uploaded to github straight from the mac), but you can go into your security settings and specifically OK it to run. The problem is, is that ALL the game files are flagged as quarantine, which presumably prevents quarantined files from interacting with other files(From my reading, quarantine is intended to prevent trojan horse attacks and worms), so the app can be run, but it can't interact with anything, so it can't find the other files necessary to actually initialize.

Removing the quarantine file lets it run normally. I'm unsure if signing the app will make the archive also read as fine, but I'm checking into it. May need to have the app signed(which isn't a big deal) and also let xcode produce the archive so it doesn't get uppity upon download.

Re: Torque 3D 3.10 Released!

Posted: Sat Apr 01, 2017 6:00 am
by Gibby
odomcl22 wrote:Still struggling with this release. I tried using precompiled, but got an error shown below:

Fatal-ISV: (/Users/jeff/Desktop/Torque3d-development2/Engine/source/platformMac/ @ 654

Platform::getExecutablePath - Failed to find main.cs!

I cannot find a solution anywhere. So, I want to compile myself. However, I don't know the steps to do that with Xcode. Does anyone have the basic steps?

I did a quick tutorial on compiling 3.10 for macOS here:

Should get you going...

Re: Torque 3D 3.10 Released!

Posted: Sat Apr 01, 2017 6:46 pm
by odomcl22
Hello All

Thanks for the follow up. Been traveling for work (as a professional I work for US Dept of ED) and it has been taking away from my personal hobbies such as this. I will give this all a good read and try. Thanks again. To answer the earlier question(s)--yup the extraction went fine. If I go inside the package content and run the executable it works just fine (terminal running in background). Not sure why this is happening. Because it work fine from my wife's mac and no workaround is needed. Likely a setting on my machine.

Re: Torque 3D 3.10 Released!

Posted: Sat Apr 01, 2017 9:49 pm
by odomcl22
JeffR wrote:Quick follow-up on this: but it looks like the binaries are being bit by something in the upload/download process and MacOS is deciding to quarantine the files, which prevents them from working properly. I remember @
User avatar
mentioning one of their guys running into this as well in retrospect, but I'm not sure where the tangle-up would be coming from as the archive is uploaded right off the mac.
Best I can think off-hand is when downloading, because it's not signed and you have to manually OK it with the OS security settings, MacOS is auto-flagging the files for quarantine.

I'll keep poking around to see how we can deal with that so it's a non-issue going forward and then get the binaries re-uploaded once I do.

For the moment, you can either compile it yourself, or you can remove the quarantine attribute by opening terminal, navigating to where the binaries folder is, and typing in:

Code: Select all

xattr -dr Torque3D-310-MacBinaries

Assuming that the extracted folder name from the archive hadn't changed. That should remove the quarantine and let it run normally.

The above worked just fine. Thank you to all for helping out. I am going to watch the video on compiling as it may be helpful in the future. Thanks!

Re: Torque 3D 3.10 Released!

Posted: Sun Apr 02, 2017 3:16 am
by JeffR
Yeah, no worries!

I should have the 'How to compile on MacOS' article up on the wiki tonight, and I'm looking into how apple wants their applications/archives properly signed to avoid this speedbump in the future, so thanks for noting the weird behavior :)

Re: Torque 3D 3.10 Released!

Posted: Wed Aug 30, 2017 9:15 pm
by Skipper
We are updating our code to the latest 3.10 engine version. It builds fine on Windows but we ran into a problem when we tried the Mac build.
We dont have a Mac to test build on but one of our colleagues does.
He can build a Vanilla T3D no problem but when he tries to build with our added in code he gets this error:

Mac Build is failing on
Line 1968 DefineTSShapeConstructorMethod( addSequence, bool,
/Users/alexwoolner/torque3d/Engine/source/ts/tsShapeConstruct.cpp:1968:1: No matching constructor for initialization of '_EngineFunctionDefaultArguments<_EngineMethodTrampoline<_TSShapeConstructoraddSequenceframe, void (const char *, const char *, S32, S32, bool, bool, const char *)>::FunctionType>' (aka '_EngineFunctionDefaultArguments<void (TSShapeConstructor *, const char *, const char *, int, int, bool, bool, const char *)>')

Macbook Pro - macOS Sierra 10.12.6 - building with XCode 8.3.3 using this tutorial

Our code builds fine on Windows and appears to run fine on three test machines but wont load on mine for some reason:
hex core Intel I7 3960X black box edition running at 3.3 Ghz.
RAM - 64 Gb
Graphics - 16 Gb spread over 2 Geforce 6800GTXs, one on each monitor.
Mobo - Asrock X79 Extreme 11. Audio is an onboard Soundblaster recon3Di.
HD - The OS and applications are on separate partitions of a 500 Gb SSD.
OS - Windows 10 Pro 64 bit.

Any ideas?

Re: Torque 3D 3.10 Released!

Posted: Wed Aug 30, 2017 9:40 pm
by Azaezel
Strange, I just built a custom one myself last night on the mini... _EngineMethodTrampoline would suggest this would be a source<->script interop binding.
One of ... fb20fba4dc or ... 4779bfde69 perhaps?

Only recent script subsystem tweaks I can think of offhand.