Torque 3D 3.9 Release Candidate

39 posts Page 2 of 4
JeffR
Steering Committee
Steering Committee
Posts: 750
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Mon Jun 13, 2016 8:02 pm
saindd wrote:I've noticed many bugs in the 3.9 OpenGL implementation that were reported since 3.7. So, it doesn't seem that much was done on that part. Is there a changelog of the fixes made to OpenGL?


Were you just noting the outstanding issues list(which does need some pruning, now), or have you noticed some issues in particular when testing?
saindd
Posts: 220
Joined: Wed Apr 15, 2015 3:20 am
by saindd » Mon Jun 13, 2016 8:34 pm
The compilation issues with libCollada, which i got past after making some minor fixes. Also, the terrain in OpenGL seems very unstable. The character falls from it in certain areas (can't give more information right now, i'm trying to find a pattern in order to report this) and there are seams in the textures whenever you use normal or parallax mapping.

There are also random crashes with large terrains, but i also wasn't able to find a pattern yet. Are there any other Linux users out there? Maybe we can help by debugging together and sharing reports :geek:
JeffR
Steering Committee
Steering Committee
Posts: 750
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Mon Jun 13, 2016 10:07 pm
saindd wrote:The compilation issues with libCollada, which i got past after making some minor fixes. Also, the terrain in OpenGL seems very unstable. The character falls from it in certain areas (can't give more information right now, i'm trying to find a pattern in order to report this) and there are seams in the textures whenever you use normal or parallax mapping.

There are also random crashes with large terrains, but i also wasn't able to find a pattern yet. Are there any other Linux users out there? Maybe we can help by debugging together and sharing reports :geek:


Some of those aren't really OpenGL, persay, but yeah, definitely need to be addressed.

If you and anyone else running Linux have more details, like logs, or video/screenshots of stuff happening, then we can get all over that. It's hard to debug stuff we can't reproduce, after all :)
LukasPJ
Site Admin
Posts: 348
Joined: Tue Feb 03, 2015 7:25 pm
 
by LukasPJ » Tue Jun 14, 2016 6:25 am
JeffR wrote:
LukasPJ wrote:When I pull, generate new projects and compile the development branch in VS2015, I get:
Severity Code Description Project File Line Suppression State
Error C1083 Cannot open include file: 'nfd.h': No such file or directory Full DLL d:\gamedev\torque3d-hobby\torque3d - 2\engine\source\platform\nativedialogs\filedialog.cpp 32



As well as:
15>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppBuild.targets(936,5): warning MSB8027: Two or more files with the name of fileDialog.cpp will produce outputs to the same location. This can lead to an incorrect build result. The files involved are ..\..\..\..\..\Engine\source\platform\nativeDialogs\fileDialog.cpp, ..\..\..\..\..\Engine\source\platformWin32\nativeDialogs\fileDialog.cpp.


How'd you generate the project? Sounds like it didn't filter the files correctly, there.


As usual, copy template to projects folder and run the generateProjects.bat I'll try and see if I can track it down later today
Timmy
Posts: 308
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Tue Jun 14, 2016 7:07 am
The old project generator is pretty much dead now, try the build again with CMake @
User avatar
LukasPJ
JeffR
Steering Committee
Steering Committee
Posts: 750
Joined: Tue Feb 03, 2015 9:49 pm
 
by JeffR » Wed Jun 22, 2016 2:21 am
Just pushed RC2, which has various improvements and fixes. It can be nabbed here.
rlranft
Posts: 298
Joined: Thu Feb 05, 2015 3:11 pm
 
by rlranft » Wed Jun 22, 2016 3:30 pm
Timmy wrote:The old project generator is pretty much dead now, try the build again with CMake @
User avatar
LukasPJ

generateProjects.bat still works fine for me - though I haven't added a vs2013 or vs2015 target yet, the vs2012 target script still does what it's supposed to do. Not sure how it can really break, after all - all it does is walk the source folder recursively and add files to the project. This results in a project with your specified parameters from the buildfiles/config/project.config file for the project at hand. Nothing really fancy here, so I'd expect it to be pretty durable.
Timmy
Posts: 308
Joined: Thu Feb 05, 2015 3:20 am
by Timmy » Wed Jun 22, 2016 3:43 pm
rlranft wrote:
Timmy wrote:The old project generator is pretty much dead now, try the build again with CMake @
User avatar
LukasPJ

generateProjects.bat still works fine for me - though I haven't added a vs2013 or vs2015 target yet, the vs2012 target script still does what it's supposed to do. Not sure how it can really break, after all - all it does is walk the source folder recursively and add files to the project. This results in a project with your specified parameters from the buildfiles/config/project.config file for the project at hand. Nothing really fancy here, so I'd expect it to be pretty durable.


Yeah i know how it works ;) . A lot of stuff has not been updated with it and 3.9 will not compile using it.
rlranft
Posts: 298
Joined: Thu Feb 05, 2015 3:11 pm
 
by rlranft » Fri Jun 24, 2016 3:23 am
Timmy wrote:Yeah i know how it works ;) . A lot of stuff has not been updated with it and 3.9 will not compile using it.

Well, to hell with that noise! I'm gonna fix it! 'Cause that's what I do! :lol:
39 posts Page 2 of 4

Who is online

Users browsing this forum: No registered users and 1 guest