AFX 3.8 Porting - Strange Build Errors

Expanding and utilizing the engine via C++.
26 posts Page 2 of 3
Azaezel
Posts: 395
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Tue Nov 17, 2015 11:03 pm
PR updated with script alts. *thiiiink* I caught em all, if someone would be so kind as to run a spot-check.
RasterRon
Posts: 53
Joined: Sun Oct 25, 2015 7:36 am
 
by RasterRon » Thu Nov 19, 2015 12:13 am
Hey Azaezel,

I'm quite interested and would like to help in trying this one out. Just to confirm, is this the link to the branch?

https://github.com/Azaezel/Torque3D/tree/afx_plus_3.8

Thanks.
Azaezel
Posts: 395
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Thu Nov 19, 2015 12:33 am
yep
Dwarf King
Posts: 165
Joined: Thu Feb 05, 2015 7:20 pm
by Dwarf King » Thu Nov 19, 2015 1:41 pm
Gibby wrote:Ahhh, found it, the 'Full_AFX' template hadn't been updated with newest shader stuff - diffing it with 'Full' made it work...

I'll bash away on it some more this eve, see if I can break anything else ;P


Good to see you around :D I kind of thought you had left us as you never answered any of my mails or forums posts :o
Gibby
Posts: 72
Joined: Wed Feb 11, 2015 2:40 pm
by Gibby » Fri Nov 20, 2015 11:51 pm
Dwarf King wrote:
Gibby wrote:Ahhh, found it, the 'Full_AFX' template hadn't been updated with newest shader stuff - diffing it with 'Full' made it work...

I'll bash away on it some more this eve, see if I can break anything else ;P


Good to see you around :D I kind of thought you had left us as you never answered any of my mails or forums posts :o


Update: I've tinkered with stock AFX and then added my own set of mods, which include many of AZ's, Acasters, Visad's and my own, and have so far not seen any other issues than I'm seeing with stock 3.8. just random crashes in the editors while in OpenGL. Anyone else out there using Az's port?

@DK: got a job :mrgreen:
J0linar
Posts: 46
Joined: Thu Feb 05, 2015 8:50 pm
by J0linar » Sun Nov 22, 2015 4:30 pm
Steve_Yorkshire
Posts: 240
Joined: Tue Feb 03, 2015 10:30 pm
 
by Steve_Yorkshire » Thu Nov 26, 2015 10:18 pm
Not found any issues playing around with Az's afx3.8 branch ... which is nice. :)
Dwarf King
Posts: 165
Joined: Thu Feb 05, 2015 7:20 pm
by Dwarf King » Wed Jan 13, 2016 9:16 pm
.... tried the branch with DX11 as well...
https://github.com/Azaezel/Torque3D/tree/afx3.8_DX11

got a bunch of shader errors...
... kind of lacking the man power to fix those issues here and now...
I am now trying this branch here:
https://github.com/Azaezel/Torque3D/tree/afx_plus_3.8

Gotta start port the project to a more modern version as I am still running on version 3.51... :roll:
Azaezel
Posts: 395
Joined: Tue Feb 03, 2015 9:50 pm
 
by Azaezel » Wed Jan 13, 2016 9:33 pm
Mind throwing out a list?

Edit: Pretty much just dropped the AFX shaders dir from the personal game right on in...
Dwarf King
Posts: 165
Joined: Thu Feb 05, 2015 7:20 pm
by Dwarf King » Wed Jan 13, 2016 10:01 pm
Azaezel wrote:Mind throwing out a list?

Edit: Pretty much just dropped the AFX shaders dir from the personal game right on in...


Oh I see :D

Well the error I got before Windows 10 decided to crash my machine during the use of Firefox... :roll: ... was:

Code: Select all

torque3d-afx3.8_dx11\engine\source\gfx\d3d9\gfxd3d9shader.cpp(824,0): {Fatal-ISV} - GFXD3D9Shader::initShader - failed to open shader 'shaders/common/fixedFunction/textureV.hlsl'.
GFXD3D9Shader::_compileShader - Failed to open shader file 'shaders/common/fixedFunction/textureV.hlsl'.
First-chance exception at 0x10866F6C (T3D_DX11_AFX_V38_DEBUG DLL.dll) in T3D_DX11_AFX_V38_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000000.
Unhandled exception at 0x10866F6C (T3D_DX11_AFX_V38_DEBUG DLL.dll) in T3D_DX11_AFX_V38_DEBUG.exe: 0xC0000005: Access violation reading location 0x00000000.


But as I can understand I will need to drop the AFX shaders dir from any current AFX project into my new build/folder structure. Right?

I will try that now.

Edit:
I read Skibby's comment as well. I took the shader files from the full template and the DX 11 version loads well now... Damn this looks promising! :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:
Last edited by Dwarf King on Thu Jan 14, 2016 12:09 am, edited 1 time in total.
26 posts Page 2 of 3

Who is online

Users browsing this forum: No registered users and 1 guest